Ed Brown MSH - Kimber Forum

Kimber


Go Back   Kimber Forum > Kimber Forum Discussions > Gunsmith

Like Tree21Likes
Reply
 
LinkBack Thread Tools Display Modes
Old 01-19-2017, 04:14 PM   #1
Junior Member
 
Join Date: Jan 2017
Posts: 22
Ed Brown MSH

Hi I just install Ed Brown mainspring housing on my Kimber and now the trigger pulls without pressing grip safty did I do something wrong
Miguel1911 is offline   Reply With Quote
Remove Ads
Old 01-19-2017, 04:16 PM   #2
Senior Member
 
Insta-Gator's Avatar
 
Join Date: Jan 2014
Location: Georgia
Posts: 11,763
Take it apart and put it back together again. Something is out of position. The MSH won't do that. We've installed too many without problems.
__________________
Insta-Gator aka .. Gary
(warning: prone to bouts of petulance)

It's not that I have something to hide, ... I have nothing I want you to see.

(remember your 4th Amendment right, people)
Insta-Gator is offline   Reply With Quote
Old 01-19-2017, 04:35 PM   #3
Junior Member
 
Join Date: Jan 2017
Posts: 22
Do I take it all apart it fit right in there but now seems like I'm always pressing the grip safety
Originally Posted by Insta-Gator View Post
Take it apart and put it back together again. Something is out of position. The MSH won't do that. We've installed too many without problems.
Miguel1911 is offline   Reply With Quote
 
Old 01-19-2017, 04:43 PM   #4
Junior Member
 
Join Date: Jan 2017
Posts: 22
I just took it apart and put the original one on and it works perfectly fine I'm going to try it again
Originally Posted by Insta-Gator View Post
Take it apart and put it back together again. Something is out of position. The MSH won't do that. We've installed too many without problems.
Insta-Gator likes this.
Miguel1911 is offline   Reply With Quote
Old 01-19-2017, 04:46 PM   #5
Banned
 
Join Date: Sep 2014
Posts: 2,773
Originally Posted by Miguel1911 View Post
Hi I just install Ed Brown mainspring housing on my Kimber and now the trigger pulls without pressing grip safty did I do something wrong
Yes. Watch a video if you need help.
montanaResident is offline   Reply With Quote
Old 01-19-2017, 04:57 PM   #6
Junior Member
 
Join Date: Jan 2017
Posts: 22
Thank you for the video that's pretty much exactly what I did I was watching the video also when I did it I took it apart and reinstalled the new one and it works fine I'm going to try it again
Originally Posted by Marshall View Post
I know that you know how to install the MSH, but I have installed a few and always do a refresh by watching this...Never had an issue...Some neat tricks in it that really helped me out...

Chuck43 and Marshall like this.
Miguel1911 is offline   Reply With Quote
Old 01-19-2017, 05:00 PM   #7
Senior Member
 
Marshall's Avatar
 
Join Date: Nov 2013
Location: Cardinal Nation
Posts: 19,285
Originally Posted by Miguel1911 View Post
Thank you for the video that's pretty much exactly what I did I was watching the video also when I did it I took it apart and reinstalled the new one and it works fine I'm going to try it again
Wow, you're quick...I deleted that as quick as I posted it because I didn't want to offend you by thinking you didn't know what you were doing...

Glad it worked out for you....
Chuck43 likes this.
Marshall is offline   Reply With Quote
Old 01-19-2017, 05:13 PM   #8
Junior Member
 
Join Date: Jan 2017
Posts: 22
I won't get offended we're here to help each other. I install the orginal plastic one and it works fine. I reinstall the new one and it does the same thing, seems like I'm always pressing the grip safety

Originally Posted by Marshall View Post
Originally Posted by Miguel1911 View Post
Thank you for the video that's pretty much exactly what I did I was watching the video also when I did it I took it apart and reinstalled the new one and it works fine I'm going to try it again
Wow, you're quick...I deleted that as quick as I posted it because I didn't want to offend you by thinking you didn't know what you were doing...

Glad it worked out for you....
Miguel1911 is offline   Reply With Quote
Old 01-19-2017, 05:20 PM   #9
Senior Member
 
Insta-Gator's Avatar
 
Join Date: Jan 2014
Location: Georgia
Posts: 11,763
Originally Posted by Miguel1911 View Post
I won't get offended we're here to help each other. I install the orginal plastic one and it works fine. I reinstall the new one and it does the same thing, seems like I'm always pressing the grip safety
Um, you're supposed to press the grip safety in order to pull the trigger. What did I miss?

Possibility: Check for clearance between the MSH and trip safety. I install a MSH on my Custom Crimson Carry II and had problems with the grip safety no depressing all the way. I used some 320 grit sand paper on a flat surface to sand down the top of the MSH just a tiny bit to allow full clearance.
__________________
Insta-Gator aka .. Gary
(warning: prone to bouts of petulance)

It's not that I have something to hide, ... I have nothing I want you to see.

(remember your 4th Amendment right, people)

Last edited by Insta-Gator; 01-19-2017 at 05:22 PM.
Insta-Gator is offline   Reply With Quote
Old 01-19-2017, 08:20 PM   #10
Junior Member
 
Join Date: Jan 2017
Posts: 22
That's the thing I am not pressing the grip safety and if I pull hard it without pushing the grip safety it will fire to the trigger

Originally Posted by Insta-Gator View Post
Originally Posted by Miguel1911 View Post
I won't get offended we're here to help each other. I install the orginal plastic one and it works fine. I reinstall the new one and it does the same thing, seems like I'm always pressing the grip safety
Um, you're supposed to press the grip safety in order to pull the trigger. What did I miss?

Possibility: Check for clearance between the MSH and trip safety. I install a MSH on my Custom Crimson Carry II and had problems with the grip safety no depressing all the way. I used some 320 grit sand paper on a flat surface to sand down the top of the MSH just a tiny bit to allow full clearance.
Miguel1911 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
My Ed Brown Sear Jig Problem! swca Kimber Talk 6 10-30-2016 11:59 AM