Kimber TLE/RL Wilson magazine help needed - Kimber Forum

Kimber


Go Back   Kimber Forum > Kimber Model Specific > Kimber 1911 Forum

Like Tree4Likes
Reply
 
LinkBack Thread Tools Display Modes
Old 07-22-2014, 07:14 PM   #1
Junior Member
 
Mr Wiggins's Avatar
 
Join Date: Jul 2014
Location: Kansas
Posts: 4
Kimber TLE/RL Wilson magazine help needed

Recently I purchased a new Kimber Custom TLE/RL II TFS 9mm to reignite my love for the 1911 platform. After reading countless threads on various forums, I decided to purchase the Wilson Combat ETM 10rd magazine. After my first trip to the range this weekend, I have come to doubt my decision.

1st Range trip
-Rounds fired in Kimber mag - No failures
-Rotated through the 3 additional WC mags and 1-2 FTE per mag
-Total 100rds fired

2nd Range trip
-Rounds fired in Kimber mag - No failures
-Rotated through the 3 additional WC mags and 1-2 FTE per mag
-Total 50rds fired

Range ammo:
LAXAMMO 9mm reloads with no prior issues in any of my other pistols or in the factory Kimber 9rd magazine.

Are there any further steps that I would need to take to determine what is causing this failure? Do the Wilson magazines need to be broke in?

In compliance with gun forum etiquette, obligatory glamor shots included.
Attached Images
File Type: jpg DSC_0047_zpsa6774833.jpg (48.4 KB, 3 views)
File Type: jpg DSC_0046_zps0b3717db.jpg (65.3 KB, 3 views)
File Type: jpg 20140722_190953.jpg (1.54 MB, 5 views)
File Type: jpg 20140720_143630.jpg (1.64 MB, 6 views)
File Type: jpg 20140720_143638.jpg (1.41 MB, 7 views)
Mr Wiggins is offline   Reply With Quote
Remove Ads
Old 07-22-2014, 07:29 PM   #2
Super Moderator
 
Islander's Avatar
 
Join Date: Jan 2014
Location: NW Ohio
Posts: 5,126
It does sound like a problem with the WC magazines. I'd try leaving them loaded until your next range visit and see if that makes a difference. Giving them a good cleaning would be my next step. I really can't believe you got three bad mags from a reputable manufacturer. Be sure to follow Kimbers cleaning and break in procedures as well. Good luck and keep us posted.
__________________
Steve

Ohio Chl holder
NRA member
Old age isn't for sissy's
Islander is offline   Reply With Quote
Old 07-23-2014, 02:57 AM   #3
Senior Member
 
Insta-Gator's Avatar
 
Join Date: Jan 2014
Location: Georgia
Posts: 11,763
Thanks for the glamour shots.
__________________
Insta-Gator aka .. Gary
(warning: prone to bouts of petulance)

It's not that I have something to hide, ... I have nothing I want you to see.

(remember your 4th Amendment right, people)
Insta-Gator is offline   Reply With Quote
 
Old 07-23-2014, 04:21 AM   #4
Senior Member
 
bhunted's Avatar
 
Join Date: Mar 2014
Location: Sumner County, TN
Posts: 2,895
I'd try some factory loads in your mags. I use LAX mostly and while all my plastic guns eat it up, my 1911's have a slight prob once in awhile...
__________________
Regards,

John, aka BHunted
NRA Life Patriot Benefactor Member - Sumner Gun - ANJRPC - GFH - Patriot Guard

"Democracy is two wolves and a lamb voting on what to have for lunch. Liberty is a well-armed lamb contesting the vote". -Benjamin Franklin

---------------------------------------
Kimber Warrior SOC
SS Raptor Pro
Ultra Covert II
bhunted is offline   Reply With Quote
Old 07-23-2014, 04:37 AM   #5
Senior Member
 
Mike240's Avatar
 
Join Date: Aug 2013
Posts: 1,704
It appears you have an extractor issue. I know it seems to only occur with the Wilson mags and those mags due seem to present the round higher than others. But if the gun is properly supported so the slide can travel fully to the rear and the empty is impacting the ejector hard enough the extractor should still release it.

Try loading the chamber dropping the mag and firing several rounds to see if you get proper ejection. I suspect the extractor needs correction.

I also did not like the performance of the Wilson 9mm mags in my TeAm Match but have run over 8k rounds with Metalform Elite 10 rounders with no complaint. The stoppages I got with the Wilson's were feed issues not the one you encountered.
__________________
Yea. Keep telling yourself that split times donít matter.

Last edited by Mike240; 07-23-2014 at 04:45 AM.
Mike240 is offline   Reply With Quote
Old 07-23-2014, 04:56 AM   #6
Senior Member
 
bhunted's Avatar
 
Join Date: Mar 2014
Location: Sumner County, TN
Posts: 2,895
Originally Posted by Mike240 View Post
It appears you have an extractor issue. I know it seems to only occur with the Wilson mags and those mags due seem to present the round higher than others. But if the gun is properly supported so the slide can travel fully to the rear and the empty is impacting the ejector hard enough the extractor should still release it.

Try loading the chamber dropping the mag and firing several rounds to see if you get proper ejection. I suspect the extractor needs correction.

I also did not like the performance of the Wilson 9mm mags in my TeAm Match but have run over 8k rounds with Metalform Elite 10 rounders with no complaint. The stoppages I got with the Wilson's were feed issues not the one you encountered.
Mike, mine were feed issues too. But with LAX, it also did it in my Colt Govt. Reason I mentioned trying factory as part of his testing.
__________________
Regards,

John, aka BHunted
NRA Life Patriot Benefactor Member - Sumner Gun - ANJRPC - GFH - Patriot Guard

"Democracy is two wolves and a lamb voting on what to have for lunch. Liberty is a well-armed lamb contesting the vote". -Benjamin Franklin

---------------------------------------
Kimber Warrior SOC
SS Raptor Pro
Ultra Covert II
bhunted is offline   Reply With Quote
Old 07-23-2014, 07:02 AM   #7
Senior Member
 
Chickadee's Avatar
 
Join Date: May 2014
Location: Colorado
Posts: 2,323
Originally Posted by Mike240 View Post
It appears you have an extractor issue. I know it seems to only occur with the Wilson mags and those mags due seem to present the round higher than others. But if the gun is properly supported so the slide can travel fully to the rear and the empty is impacting the ejector hard enough the extractor should still release it.

Try loading the chamber dropping the mag and firing several rounds to see if you get proper ejection. I suspect the extractor needs correction.

I also did not like the performance of the Wilson 9mm mags in my TeAm Match but have run over 8k rounds with Metalform Elite 10 rounders with no complaint. The stoppages I got with the Wilson's were feed issues not the one you encountered.

When I was having issues with my Super Carry (fixed by Kimber by adjusting the extractor) the problem was worse with the WC mags. Now it runs flawlessly with either mag. Just my 2 cents ...

https://www.kimbertalk.com/forums/kim...ht=super+carry
Chuck43 likes this.
__________________
If everything seems under control, you're just not going fast enough.

Mario Andretti
Chickadee is offline   Reply With Quote
Old 07-23-2014, 07:40 AM   #8
Senior Member
 
Insta-Gator's Avatar
 
Join Date: Jan 2014
Location: Georgia
Posts: 11,763
There's really no reason to struggle with a pistol that is presenting problems. Kimber customer service has repeatedly demonstrated to others and myself that they are interested in having satisfied customers. Give them a call. If they want the gun returned, they'll send you via email a UPS shipping label. All you have to do is box it up and deliver it to the UPS facility (not a UPS Store in a shopping center.) In a short time your pistol will be returned to your home (someone 21 years old must be there to sign for the delivery.)
__________________
Insta-Gator aka .. Gary
(warning: prone to bouts of petulance)

It's not that I have something to hide, ... I have nothing I want you to see.

(remember your 4th Amendment right, people)
Insta-Gator is offline   Reply With Quote
Old 07-23-2014, 11:38 AM   #9
Senior Member
 
Lineman's Avatar
 
Join Date: Feb 2014
Location: Beautiful Downtown Monroe, GA
Posts: 3,765
Talking My 2 Cents Worth!!

The solution seems obvious to me! If your pistol functions well with Kimber factory magazines.........USE KIMBER FACTORY MAGAZINES!!!! If it ain't broke; no need to fix it!!!

I have an answer to a magazine that fails to function properly!! See attached photo below:
That Left a Mark!!.JPG
This cure worked for me on a defective 8 round Chip McCormick Shooting Star mag. CMC sent me two new 8 rounders. They work just fine!! I mounted the dead magazine on a plaque and it is now on the wall in my Man Cave/Computer room!! Some trophy, huh? pound.gifpound.gifpound.gif
TROPHY CMC MAG I.JPG
Chuck43 and bhunted like this.
__________________
The Lineman-Proud Army Dad!!
--Keith



Obama called me a CLINGER! Terrorists call me an INFIDEL!
Hillary calls me DEPLORABLE! Trump calls me an AMERICAN!!


Kimber Stainless Ultra Raptor II .45 ACP
Kimber Pro Carry II .45 ACP
NRA Member 45+ Years
Georgia Carry.Org Member
Wounded Warrior Project Supporter
Lineman is offline   Reply With Quote
Old 07-26-2014, 07:22 PM   #10
Junior Member
 
Mr Wiggins's Avatar
 
Join Date: Jul 2014
Location: Kansas
Posts: 4
Thank you for all the ideas and feedback!!! The information has been great.

I had a few minutes to swing by the range and try some of them this week. Here is what I was able to accomplish in time that I had...

1. Load the magazines a couple days before the range visit
2. Clean the magazines (they were new when the problem started but I did it anyway)
3. Clean the pistol again after the initial 150rds and follow the Kimber cleaning guidelines
4. Most importantly, create a control group for a follow up range visit...since the TLE was my only 1911 I had no choice but to buy another Kimber to validate your concerns. Yes Jr. Cherubs, you are the biggest bunch of enablers I have ever seen!!! Do you normally stop at two???

I guess you want to know the results from steps 1-3...
1. The failures were reduced to only 2x's in 8 magazines.

Kimber control group attached:Kimber Ultra Aegis II
Attached Images
File Type: jpg DSC_0067.jpg (1.08 MB, 1 views)
File Type: jpg DSC_0071.jpg (1.00 MB, 1 views)
Insta-Gator likes this.

Last edited by Mr Wiggins; 07-26-2014 at 07:24 PM.
Mr Wiggins is offline   Reply With Quote
Reply


Search tags for this page
9mm kimber tle break in
,
9mm kimberling the failure
,
kimber 9mm ejector issue
,

kimber custom 2 tle/rl tfs review

,
kimber tle rl 9mm
,
kimber tle rl tfs review
,
king mber tle 9mm
,
magazine kimber tle tfs 1911
Click on a term to search for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Classic custom help needed dave800 Kimber 1911 Forum 11 05-05-2014 04:35 PM
Wilson Combat Magazine Sale Islander Off-Topic Discussion Forum 5 04-15-2014 05:57 PM
Honest opinion needed. Marshall Off-Topic Discussion Forum 35 03-19-2014 09:52 AM
Wilson Magazine help toyrrnut New Member Introduction 14 02-15-2014 06:48 AM