New Eclipse II - Kimber Forum

Kimber


Go Back   Kimber Forum > Kimber Model Specific > Kimber 1911 Forum

Like Tree2Likes
Reply
 
LinkBack Thread Tools Display Modes
Old 01-18-2015, 07:04 PM   #1
Junior Member
 
Join Date: Jan 2015
Posts: 5
New Eclipse II

New to 1911s just got my first which is an Eclipse II just got home from the range and was cleaning the gun and noticed brass marks behind ejection port. Is this normal or what needs adjusted. The gun ran perfect
Wasabi likes this.
btoh87 is offline   Reply With Quote
Remove Ads
Old 01-18-2015, 07:06 PM   #2
Senior Member
 
Insta-Gator's Avatar
 
Join Date: Jan 2014
Location: Georgia
Posts: 11,761
Congrats. If it ain't broke, don't fix it. Welcome to KT.
Dons1911 likes this.
__________________
Insta-Gator aka .. Gary
(warning: prone to bouts of petulance)

It's not that I have something to hide, ... I have nothing I want you to see.

(remember your 4th Amendment right, people)
Insta-Gator is offline   Reply With Quote
Old 01-18-2015, 07:12 PM   #3
Super Moderator
 
Chuck43's Avatar
 
Join Date: Jul 2013
Location: Northern Illinois
Posts: 34,068
Welcome to the forum from northern Illinois btoh87.
__________________
WE DON'T SHOOT TO KILL, WE SHOOT TO SAVE A LIFE.
Chuck43 is offline   Reply With Quote
 
Old 01-18-2015, 07:15 PM   #4
Senior Member
 
Dude22's Avatar
 
Join Date: Dec 2013
Location: South West Florida
Posts: 5,885
Welcome from Ohio!
__________________
Denny

KEEP CALM AND RETURN FIRE

NRA Life Member
Dude22 is offline   Reply With Quote
Old 01-18-2015, 07:36 PM   #5
Junior Member
 
Join Date: Jan 2015
Posts: 5
Thanks guys
btoh87 is offline   Reply With Quote
Old 01-18-2015, 09:44 PM   #6
Junior Member
 
ckduallie's Avatar
 
Join Date: Nov 2014
Posts: 28
Congratulations and welcome!
ckduallie is offline   Reply With Quote
Old 01-18-2015, 09:52 PM   #7
Senior Member
 
glokrok's Avatar
 
Join Date: May 2014
Location: Texas
Posts: 2,523
Greetings from Texas! What kind of ammo?
__________________
glokrok.com
glokrok is offline   Reply With Quote
Old 01-19-2015, 05:31 AM   #8
Senior Member
 
Ultraman's Avatar
 
Join Date: Feb 2014
Location: South Lake Tahoe CA
Posts: 868
Originally Posted by btoh87 View Post
New to 1911s just got my first which is an Eclipse II just got home from the range and was cleaning the gun and noticed brass marks behind ejection port. Is this normal or what needs adjusted. The gun ran perfect
Normal. Congrats on a beautiful pistol.
Ultraman is offline   Reply With Quote
Old 01-19-2015, 05:48 AM   #9
Senior Member
 
Deputy347k9's Avatar
 
Join Date: Jan 2015
Location: Havelock, NC
Posts: 390
Congratulations and welcome my friend!
Deputy347k9 is offline   Reply With Quote
Old 01-19-2015, 08:15 AM   #10
Senior Member
 
Jflytle's Avatar
 
Join Date: Jan 2015
Location: Northern ILL
Posts: 3,874
Welcome from Northern ILL. As others have indicated, seems normal. As long as it is not jamming up, leave it alone.
Jflytle is offline   Reply With Quote
Reply


Search tags for this page

brass marks behind ejection port on1911

Click on a term to search for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kimber Eclipse II Chuck43 Kimber Talk 25 09-06-2015 03:53 PM
My Eclipse Custom II bldr52 Kimber 1911 Forum 25 04-17-2015 06:48 PM
KG Holster For My Eclipse Chuck66 Kimber Talk 14 05-04-2014 08:36 PM
New Eclipse, I have an addiction. wolf1956 Kimber 1911 Forum 10 04-12-2014 11:44 AM
New Custom Eclipse II smlsuperman Kimber 1911 Forum 3 04-21-2013 12:59 PM