5/7 98% - Kimber Forum

Kimber


Go Back   Kimber Forum > Kimber Model Specific > Kimber Micro Carry Forum

Like Tree1Likes
  • 1 Post By glokrok
Reply
 
LinkBack Thread Tools Display Modes
Old 05-08-2016, 10:46 AM   #1
Senior Member
 
Join Date: Dec 2015
Posts: 2,332
5/7 98%

Brought my Micro along to the range yesterday. There've been so many good reports lately, mine included, I wanted to double check :-)
I decided to give it a go with the 7 round mags, have used the 6s last few times, and 100 rounds of Fiocchi 95gr FMJ (red box). I think I do better if I use either the 6s or 7s, switching back and forth leaves my pinky confused.
...anyways last round of second mag, click... no bang! I held for 30 seconds, racked the slide and out popped the cartridge? Before racking the slide I didn't confirm that it was fully in battery and there was no mark on the primer? I loaded that round first and completely reloaded both mags. When I came to that round again (same mag) it wound up not loading properly, bullet pointed up?
...next time around it fired properly and other than those instances everything did what it should? When I cleaned up later I pulled the firing pin, both it and the spring looked fine. Although the recoil spring has less than 400 rounds it was about 1/2 inch shorter than a new one so I replaced it. Any thoughts?
...target is at 25'
Attached Images
File Type: jpg photo.JPG (1.75 MB, 15 views)
cousinmark is offline   Reply With Quote
Remove Ads
Old 05-08-2016, 11:13 AM   #2
Senior Member
 
glokrok's Avatar
 
Join Date: May 2014
Location: Texas
Posts: 2,521
Nice shooting, Cuz! Good report!
cousinmark likes this.
__________________
glokrok.com
glokrok is offline   Reply With Quote
Old 05-08-2016, 12:36 PM   #3
Member
 
Join Date: Apr 2016
Location: Las Vegas
Posts: 38
Originally Posted by cousinmark View Post
Brought my Micro along to the range yesterday. There've been so many good reports lately, mine included, I wanted to double check :-)
I decided to give it a go with the 7 round mags, have used the 6s last few times, and 100 rounds of Fiocchi 95gr FMJ (red box). I think I do better if I use either the 6s or 7s, switching back and forth leaves my pinky confused.
...anyways last round of second mag, click... no bang! I held for 30 seconds, racked the slide and out popped the cartridge? Before racking the slide I didn't confirm that it was fully in battery and there was no mark on the primer? I loaded that round first and completely reloaded both mags. When I came to that round again (same mag) it wound up not loading properly, bullet pointed up?
...next time around it fired properly and other than those instances everything did what it should? When I cleaned up later I pulled the firing pin, both it and the spring looked fine. Although the recoil spring has less than 400 rounds it was about 1/2 inch shorter than a new one so I replaced it. Any thoughts?
...target is at 25'
I replaced my spring because it was shorter and allowing excessive slide movement.

No problems with the Wolff spring.
Chillis is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On