Range report...happy and frustrated - Kimber Forum

Kimber


Go Back   Kimber Forum > Kimber Model Specific > Kimber Revolver Forum

Like Tree10Likes
Reply
 
LinkBack Thread Tools Display Modes
Old 02-27-2017, 03:28 PM   #1
Senior Member
 
Snowflake9mm's Avatar
 
Join Date: Jun 2016
Location: Winter Park, FL
Posts: 205
Range report...happy and frustrated

Okay guys, took the new K6 and my Micro 9 to the range today.

For the K6 I bought a box of Remington .357 125gr, Remington .38 130 gr and a box of Federal .38 +p.

I started with the .357... WOW! What a kick!!!! Surprised me but I like it and was still able to get a nice grouping with 4 almost on top of each other.

With .38's recoil is much more manageable for me and still very accurate. I'm actually amazed at how accurate. Sights are good for me. I don't seem to have issues with just the black sights. The trigger is amazingly easy and smooth for a double action. I put 106 rounds thru it and only had 1 small issue. After the 1st 6 rounds when I went to reload, a round wouldn't go into one of the cylinders. Finally realized there was some kind of sticky debris in the chamber. Cleaned it out and no more issues.

Overall I am very pleased! Picks and short video below.

As for the frustrating part, I'm very disappointed in my Micro 9. It may be going back to Kimber again. At one point in the middle of a mag, the slide only 1/2 cocked the hammer. Then on the next mag, last round failed to fire and was jammed so bad the range officer had to bring over a soft mallet to get it to move into position. We fired the round and then the casing wouldn't eject. Slide completely stuck again. RO had to help me with a rod into the barrel and soft mallet again to break it loose. Hubby just isn't confident with me carrying the 9 anymore. When it works, it's great. Accurate, easy to shoot and carry but I guess you do have to be able to rely on it. Will see what Kimber has to say.





Gotta play with video to get it to upload. Will do that later.


Sent from my iPhone using Tapatalk
Chuck43, 2sharp2, Hoffbrew and 2 others like this.
__________________
Deb

"I do not carry a pistol so I can impose my will on someone else. I carry a pistol so someone else cannot impose their will on me! - Lynn Givens, Rangemaster"
Snowflake9mm is offline   Reply With Quote
Remove Ads
Old 02-27-2017, 03:49 PM   #2
Senior Member
 
Hoffbrew's Avatar
 
Join Date: Apr 2015
Location: Central California
Posts: 2,884
Glad to hear good on K6s, that is great! Sorry to hear about the M9, hopefully you can get that running again to carry.
__________________
NRA Life Member
USCCA


Always be ready - 5.11
Hoffbrew is offline   Reply With Quote
Old 02-27-2017, 03:55 PM   #3
Senior Member
 
Snowflake9mm's Avatar
 
Join Date: Jun 2016
Location: Winter Park, FL
Posts: 205
Originally Posted by Hoffbrew View Post
Glad to hear good on K6s, that is great! Sorry to hear about the M9, hopefully you can get that running again to carry.


Yeah, I have no idea what the issue is this time. Cleaned and oiled it really well before going to range and only got 2 mags thru it..


Sent from my iPhone using Tapatalk
__________________
Deb

"I do not carry a pistol so I can impose my will on someone else. I carry a pistol so someone else cannot impose their will on me! - Lynn Givens, Rangemaster"
Snowflake9mm is offline   Reply With Quote
 
Old 02-27-2017, 04:00 PM   #4
Senior Member
 
Hoffbrew's Avatar
 
Join Date: Apr 2015
Location: Central California
Posts: 2,884
maybe too much oil??? did you wipe it down after the hiccup? bore snake it once or twice? Just a thought..
__________________
NRA Life Member
USCCA


Always be ready - 5.11
Hoffbrew is offline   Reply With Quote
Old 02-27-2017, 04:22 PM   #5
Senior Member
 
Nellybelle's Avatar
 
Join Date: Mar 2013
Location: Midwest
Posts: 1,545
It is a mechanical tool. Keep at it until KIMBER gets it working correctly . It will be worth the work.
Nellybelle is offline   Reply With Quote
Old 02-27-2017, 04:36 PM   #6
Senior Member
 
Snowflake9mm's Avatar
 
Join Date: Jun 2016
Location: Winter Park, FL
Posts: 205
Originally Posted by Hoffbrew View Post
maybe too much oil??? did you wipe it down after the hiccup? bore snake it once or twice? Just a thought..


I don't think so... same as usual and no after the 2 issues I just packed it up..


Sent from my iPhone using Tapatalk
__________________
Deb

"I do not carry a pistol so I can impose my will on someone else. I carry a pistol so someone else cannot impose their will on me! - Lynn Givens, Rangemaster"
Snowflake9mm is offline   Reply With Quote
Old 02-27-2017, 04:38 PM   #7
Senior Member
 
Snowflake9mm's Avatar
 
Join Date: Jun 2016
Location: Winter Park, FL
Posts: 205
Originally Posted by Nellybelle View Post
It is a mechanical tool. Keep at it until KIMBER gets it working correctly . It will be worth the work.


Yeah Nelly, would love it to work right so I can keep it. I do really like how it fits me and when it works it's great!! Will see what Kimber says.


Sent from my iPhone using Tapatalk
__________________
Deb

"I do not carry a pistol so I can impose my will on someone else. I carry a pistol so someone else cannot impose their will on me! - Lynn Givens, Rangemaster"
Snowflake9mm is offline   Reply With Quote
Old 02-27-2017, 05:01 PM   #8
Senior Member
 
Albert.Cairns's Avatar
 
Join Date: Mar 2015
Posts: 1,785
9mm ammo type? Sounds like a bad batch of ammo. Light powder load 1/2 cock and sizing issue on locked up round. Bullet was probably into the rifling before lockup. JMO.


Sent from my iPhone using Tapatalk
Cybercycle likes this.
Albert.Cairns is offline   Reply With Quote
Old 02-27-2017, 06:37 PM   #9
Senior Member
 
DGM1962's Avatar
 
Join Date: Oct 2014
Location: Bethany(Oklahoma City) Oklahoma
Posts: 715
Guess it is a little discerning the problems with the Micro 9.
I am to pick up mine in a day or two. Hope it isn't a problem child.
Hope you get it running........
DGM1962 is offline   Reply With Quote
Old 02-28-2017, 07:06 AM   #10
Senior Member
 
Cybercycle's Avatar
 
Join Date: Jan 2016
Location: Middle TN
Posts: 1,463
Looks like you and the K6 get along just fine...that's a great range report on your new revolver. As for the M9 issues, I wouldn't discount the possibility of "bad" ammo as Albert.Cairns said. At one time I had similar issues with my Micro 380. During one range visit I experienced FTF and FTE issues that were frustrating and disappointing...this was while using one of the more popular ammo suppliers here. Having seen this kind of thing before, I decided to try using another brand of ball ammo and found that when I switched (same weight and construction) the little Micro worked just fine. I later sent the "bad" ammo back to the manufacturer and they replaced it saying only that it did not meet their quality standards. I suspect the loads were "light" on powder and just wouldn't cycle the pistol. These things happen, but if your M9 worked fine before, I'd certainly consider giving it another try with another brand of ammo.

I'm not sure if that is the issue with your M9, but let us know if you decide to try it again with a different brand/load.
Tejun and Snowflake9mm like this.
__________________
US Air Force 1969 - 1972
Tennessee HCP
NRA Member
OGCA - Life Member
Cybercycle is offline   Reply With Quote
Reply


Search tags for this page
k6s problems
,
kimber k6 issues
,

kimber k6 problems

,
kimber k6s complaints
,

kimber k6s problems

Click on a term to search for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On