8400 clasic follower problem - Kimber Forum

Kimber


Go Back   Kimber Forum > Kimber Model Specific > Kimber Rifles Forum

Like Tree4Likes
  • 4 Post By Insta-Gator
Reply
 
LinkBack Thread Tools Display Modes
Old 02-15-2015, 02:05 AM   #1
Junior Member
 
Join Date: Feb 2015
Posts: 4
8400 clasic follower problem

G'day guys just new to all this stuff . I'm a aussie Hound hunter we hunt sambar Deer over sent trailing hounds.I use a 8400 classic in 30-06 and occasionally when shooting at a fast moving deer through thick scrub the rounds feed up on a slight angle and the bolt moves strait over it. I've played around with it by just quickly unloading the rifle and seen what it was doing. I love the rifle but it has let me down and I'm losing deer and confidence any help or tips would be great

Last edited by sambar 75; 02-15-2015 at 02:40 AM.
sambar 75 is offline   Reply With Quote
Remove Ads
Old 02-15-2015, 05:49 AM   #2
Senior Member
 
Gmountain's Avatar
 
Join Date: Oct 2013
Location: Florida
Posts: 3,178
Are you sure the mag spring is oriented correctly and the follower installed correctly?
Gmountain is offline   Reply With Quote
Old 02-15-2015, 07:32 AM   #3
Senior Member
 
Marshall's Avatar
 
Join Date: Nov 2013
Location: Cardinal Nation
Posts: 19,254
G'Day mate...
There was another from the land of Oz yesterday with the same issue...
Hope you figure it out..
Marshall is online now   Reply With Quote
 
Old 02-15-2015, 07:52 AM   #4
Senior Member
 
Insta-Gator's Avatar
 
Join Date: Jan 2014
Location: Georgia
Posts: 11,763
Jeff, it's the same guy. Put down the Skyy.
Insta-Gator is offline   Reply With Quote
Old 02-21-2015, 06:49 PM   #5
Junior Member
 
Join Date: Jan 2015
Posts: 2
I have an 8400 Classic in 270WSM. The last round in the magazine will pop out of the rails and lie loose on top of the follower in the magazine.
gibo1973 is offline   Reply With Quote
Old 02-21-2015, 08:59 PM   #6
Senior Member
 
Join Date: Mar 2014
Location: Nevada
Posts: 2,446
Originally Posted by sambar 75 View Post
G'day guys just new to all this stuff . I'm a aussie Hound hunter we hunt sambar Deer over sent trailing hounds.I use a 8400 classic in 30-06 and occasionally when shooting at a fast moving deer through thick scrub the rounds feed up on a slight angle and the bolt moves strait over it. I've played around with it by just quickly unloading the rifle and seen what it was doing. I love the rifle but it has let me down and I'm losing deer and confidence any help or tips would be great
You're supposed to drop them with the first shot ...



__________________
Richard
NRA Life Member - 1982
Richard is offline   Reply With Quote
Reply


Search tags for this page

kimber 8400 magazine follower

,

kimber 8400 problem

,

kimber hunter magazine problem

,

polymer follower on kimber 8400 rifle

,

sambar deer hunting talk forums

Click on a term to search for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Kimber 8400 davidcalvin Kimber Rifles Forum 4 08-08-2014 08:29 AM
Kimber 8400 Police Tactical .300 Win. Mag. billt Kimber Rifles Forum 7 06-20-2014 05:50 AM
I think I have a problem Joncooper Kimber Talk 19 03-13-2014 04:16 PM
New Kim-pro mag. has busted follower FLSTF Kimber Talk 13 01-29-2014 04:30 PM
Problem with my mag, please help! bullseye0169 Kimber 1911 Forum 2 09-04-2013 02:57 PM