Solo 9 - Kimber Forum

Kimber


Go Back   Kimber Forum > Kimber Model Specific > Kimber Solo Forum

Like Tree4Likes
Reply
 
LinkBack Thread Tools Display Modes
Old 04-26-2015, 09:56 PM   #1
Junior Member
 
Join Date: Apr 2015
Posts: 1
Solo 9

Recently bought a Kimber Solo 9. My son said I would not be disappointed for buying it. I can say I bought my first and last Kimber. My pistol jams 90% of the time. I was shooting the recommended ammo of 147 gr. Want but another. Sorry I bought this one.
TxFireman is offline   Reply With Quote
Remove Ads
Old 04-27-2015, 12:57 AM   #2
Senior Member
 
Paul Neuhaus's Avatar
 
Join Date: Sep 2014
Location: Surprise, AZ
Posts: 127
Did you strip and reassemble it at all before firing it? Most new Solo owners put the slide stop in wrong, which causes the slide to lock open between rounds.

Otherwise, call Kimber, and they'll take care of it for you.
Paul Neuhaus is offline   Reply With Quote
Old 04-27-2015, 05:15 AM   #3
YuK
Member
 
YuK's Avatar
 
Join Date: Aug 2014
Location: Brooklyn NY
Posts: 91
Originally Posted by Paul Neuhaus View Post
Did you strip and reassemble it at all before firing it? Most new Solo owners put the slide stop in wrong, which causes the slide to lock open between rounds.

Otherwise, call Kimber, and they'll take care of it for you.
Just go to kimberamerica.com-support-video-solo assembly
Paul Neuhaus likes this.
YuK is offline   Reply With Quote
 
Old 04-27-2015, 05:59 AM   #4
Super Moderator
 
Chuck43's Avatar
 
Join Date: Jul 2013
Location: Northern Illinois
Posts: 32,688
Welcome to the forum from northern Illinois TxFireman, I'm sorry to hear you're having problems with your Solo unfortunately you're not alone. As was already suggested contact Kimbers customers service and get it in for service.

Customer Service
Toll-Free: (888) 243-4522
Hours: M–F, 9 a.m.–7 p.m. Eastern
__________________
WE DON'T SHOOT TO KILL, WE SHOOT TO SAVE A LIFE.
Chuck43 is online now   Reply With Quote
Old 04-27-2015, 06:06 AM   #5
Senior Member
 
Oreste's Avatar
 
Join Date: Jan 2014
Posts: 362
As disappointed has I have become, it really sounds as though you may have missed the slide stop spring when reassembling.
Nellybelle likes this.
__________________
Above all else, be armed. - Nicolo Machiavelli
Oreste is offline   Reply With Quote
Old 04-27-2015, 07:05 AM   #6
Senior Member
 
Paul Neuhaus's Avatar
 
Join Date: Sep 2014
Location: Surprise, AZ
Posts: 127
Originally Posted by YuK View Post
Just go to kimberamerica.com-support-video-solo assembly
Yep! I was one of those guys who was too stubborn the read the manual and made the mistake of not catching the spring under the slide stop. My Solo CDP has never failed me since then.
Paul Neuhaus is offline   Reply With Quote
Old 05-25-2015, 11:59 AM   #7
Junior Member
 
Join Date: May 2015
Posts: 5
I have owned 2 Solos both have been dependable. The second is a CDP. I did have some feed issues with 147gr. 124's have worked best for me.
stevendk is offline   Reply With Quote
Old 05-25-2015, 02:57 PM   #8
Super Moderator
 
Chuck43's Avatar
 
Join Date: Jul 2013
Location: Northern Illinois
Posts: 32,688
Welcome to the forum from northern Illinois stevendk.
__________________
WE DON'T SHOOT TO KILL, WE SHOOT TO SAVE A LIFE.
Chuck43 is online now   Reply With Quote
Old 06-22-2015, 10:51 AM   #9
Senior Member
 
Join Date: Jan 2013
Posts: 465
He didn't say it was locking open! said it was jamming! I read that as FTE's...
sbubrick is offline   Reply With Quote
Old 06-22-2015, 11:06 AM   #10
Senior Member
 
Join Date: Feb 2015
Posts: 133
What ammo are oyu using? I know you say you are using the recommended 147 gr ammo, but do you mean you are simply using 147 gr ammo, or are you using the specific ammo they recommend. Taht ammo is: Federal® Hydra-Shok® JHP
• Remington® Golden Saber™ HPJ
• Hornady TAP® JHP

If it doesn't work with those, call Kimber and send it back. You can also try Remington 124 gr Ultimate Defense, which is basically a rebranded Golden Sabre. I shoot and carry those in my Solo, they have been 100 percent reliable.

I have tried a lot of 147 gr ammo that doesn't work, but my Solo does work with the recommended ammo. I have some FTE in the beginning but nowhere near 90 percent as you say. I did send mine back and received it 2 1/2 weeks later in working order. Between that and shooing it a lot to break it in, it now functions 100 percent of the time with 1000 rounds through it. It is my EDC.
kwwms01 likes this.
Holster is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On