Slide Lock position - Kimber Forum

Kimber


Go Back   Kimber Forum > Kimber Model Specific > Kimber Solo Forum

Like Tree3Likes
Reply
 
LinkBack Thread Tools Display Modes
Old 05-18-2015, 08:30 PM   #1
Junior Member
 
Join Date: May 2015
Posts: 14
Slide Lock position

Hello everyone.

I just picked up a new Solo and have a question.
The slide lock is positioned correctly and the spring is positioned in the notch as it is supposed to be.
The slide lock is not completely parallel to the slide and the rear is slightly lower than the front. There is some play if you push up on the rear of the slide lock.
This might be normal as it is exactly as it it shown on the Kimber Website re-assembly.
But, I checked out a new Solo Sapphire today and the slide lock was was parallel to the slide...you could not push the rear of the slide lock up at all.

If you have a Solo, could you maybe check yours and see if there is any play and you can push up on the rear of the slide lock?

Thanks in advance.
MBSL500 is offline   Reply With Quote
Remove Ads
Old 05-18-2015, 08:36 PM   #2
Senior Member
 
Nellybelle's Avatar
 
Join Date: Mar 2013
Location: Midwest
Posts: 1,545
Mine is out in the car but I think it should be parallel. Catch the small spring in the groove of the slide stop. There should be small tension on the slide stop when you push down and it should spring back up. I can check in the morning is someone else doesn't answer back.
Nellybelle is offline   Reply With Quote
Old 05-18-2015, 08:52 PM   #3
Senior Member
 
Join Date: Apr 2013
Location: Florida
Posts: 1,587
Just wanted to welcome you to the forum.I know nothing about the Solo,but thier are many knowledgable people here that will get you squared away.Best wishes and welcome.
MPO Southy is offline   Reply With Quote
 
Old 05-18-2015, 09:09 PM   #4
Senior Member
 
Hoffbrew's Avatar
 
Join Date: Apr 2015
Location: Central California
Posts: 2,897
There is just a tad of play with no mag, solid as can be with mag, hot or cold. Make sure that slide stop pops in.
Hoffbrew is offline   Reply With Quote
Old 05-18-2015, 09:12 PM   #5
Junior Member
 
Join Date: May 2015
Posts: 14
Originally Posted by Nellybelle View Post
Mine is out in the car but I think it should be parallel. Catch the small spring in the groove of the slide stop. There should be small tension on the slide stop when you push down and it should spring back up. I can check in the morning is someone else doesn't answer back.
Are you sure? According to the video, there should be tension when you push the slide lock up and it should spring back down.
5Wire likes this.
MBSL500 is offline   Reply With Quote
Old 05-18-2015, 09:21 PM   #6
Senior Member
 
Hoffbrew's Avatar
 
Join Date: Apr 2015
Location: Central California
Posts: 2,897
That is correct. Double check that spring.
5Wire likes this.
Hoffbrew is offline   Reply With Quote
Old 05-18-2015, 09:28 PM   #7
Senior Member
 
Hoffbrew's Avatar
 
Join Date: Apr 2015
Location: Central California
Posts: 2,897
That spring should not be in the "U" groove, should be on the side groove.
Hoffbrew is offline   Reply With Quote
Old 05-18-2015, 09:31 PM   #8
Senior Member
 
Join Date: Dec 2013
Posts: 135
^^^ Pushing the slide lock up against the spring is the only way it engages correctly ^^^
Hoffbrew likes this.
5Wire is offline   Reply With Quote
Old 05-18-2015, 09:37 PM   #9
Junior Member
 
Join Date: May 2015
Posts: 14
Originally Posted by Hoffbrew View Post
There is just a tad of play with no mag, solid as can be with mag, hot or cold. Make sure that slide stop pops in.
I'm confused. If you'll watch the Kimber / Support / Solo/ Reassembly video, mine is identical. Yet the sappire I checked out today there was no play.
Very strange
MBSL500 is offline   Reply With Quote
Old 05-19-2015, 12:10 AM   #10
YuK
Member
 
YuK's Avatar
 
Join Date: Aug 2014
Location: Brooklyn NY
Posts: 91
Originally Posted by MBSL500 View Post
I'm confused. If you'll watch the Kimber / Support / Solo/ Reassembly video, mine is identical. Yet the sappire I checked out today there was no play.
Very strange
It will not play if you check it with the empty magazine in.
It should play with the loaded magazine or when magazine is out
YuK is offline   Reply With Quote
Reply


Search tags for this page

kimber solo slide stop wrong position

Click on a term to search for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
slide stop on UC II won't let go hydro333 Gunsmith 24 03-04-2015 11:37 PM
Training Body Position Chuck43 Training Videos 0 11-07-2014 04:48 PM
Did your gun come with a cable lock? Gmountain Kimber Talk 14 02-10-2014 05:15 PM
Slide won't lock open tp155 Kimber Solo Forum 23 01-11-2014 01:47 PM
What position to store the 1911 Brick Kimber 1911 Forum 9 12-12-2013 05:23 PM