Solo Problems - Kimber Forum

Kimber


Go Back   Kimber Forum > Kimber Model Specific > Kimber Solo Forum

Like Tree12Likes
Reply
 
LinkBack Thread Tools Display Modes
Old 08-11-2015, 06:13 PM   #1
Member
 
Join Date: Aug 2015
Location: Pensacola, FL
Posts: 43
Solo Problems

Greetings all, My solo was sent to the factory for the feeding and ejecting issues recently. Since its return, it has fed/shot everything I loaded into the magazine. Last week, I cleaned it and reassembled it and loaded it and carried it. This week I went to unload it, removed magazine and when I went to rack the slide back, the slide only moved a small amount. Not a comfortable thing with a round in the chamber. Eventually the round fell out, but it still took some shaking and rattling before the slide moved normally. I called Kimber and was told I should unload the gun every night and that I should take it to the range and shoot it. I said no and no. Today was my first opportunity to disassembled the pistol and as I was smearing oil on the bottom side of the slide over the firing pin area, I noticed the little set screw or what ever that is, to be misshaped and have a rough edge. Could this be my problem? Anyone else experience something like this? Thanks. Yes, I will be calling Kimber in the morning.
Attached Images
File Type: jpg IMG_7876.JPG (81.3 KB, 21 views)

Last edited by Metal Storm; 08-13-2015 at 12:33 PM. Reason: added picture
Metal Storm is offline   Reply With Quote
Remove Ads
Old 08-11-2015, 06:50 PM   #2
Member
 
Join Date: Aug 2015
Location: Pensacola, FL
Posts: 43
On second thought, I imagine the bur on the screw had nothing to do with the slide locking up. It still amazed me with the customer service comments. I didn't have my pistol serial number and they could not find me by any other way, which is why the pistol had not been returned already. Thanks again.
Metal Storm is offline   Reply With Quote
Old 08-11-2015, 07:18 PM   #3
Super Moderator
 
Chuck43's Avatar
 
Join Date: Jul 2013
Location: Northern Illinois
Posts: 32,705
Welcome to the forum from northern Illinois Metal Storm, I'm not a Solo owner but we have a bunch of them here and I'm sure you will be hearing from them soon.
__________________
WE DON'T SHOOT TO KILL, WE SHOOT TO SAVE A LIFE.
Chuck43 is offline   Reply With Quote
 
Old 08-11-2015, 07:33 PM   #4
Senior Member
 
Nellybelle's Avatar
 
Join Date: Mar 2013
Location: Midwest
Posts: 1,545
First question is did you place the slide stop spring in the slide stop groove?

I just re-read your post. I doubt if the spring has anything to do with it.
Chuck43 likes this.

Last edited by Nellybelle; 08-11-2015 at 07:35 PM.
Nellybelle is offline   Reply With Quote
Old 08-11-2015, 07:40 PM   #5
Senior Member
 
2sharp2's Avatar
 
Join Date: Jan 2014
Location: Chattanooga
Posts: 11,238
Not a Solo owner so I won't say anything except good luck, strange suggestion from customer service.
Chuck43 likes this.
__________________
The Kimber Family

CDP & RCP Ultra's
Classic Carry Pro (Factory Bone Grips)
Custom Two-Tone 45/.460Rowland
Gold Combat Limited Edition
Master Carry Pro
Sapphire Ultra 9mm
SIS Custom, Pro, Ultra
Stainless Ultra Carry 9mm
Stainless Raptor Custom, Pro, Ultra
Super Carry Ultra Plus
TLE Pro (TFS)

84M Longmaster Classic SS .308
SVT 22lr Stainless Fluted Bull Barrel
Kimber Of America 82 Stainless Fluted .22lr
84M Varmint Stainless 204 Ruger
2sharp2 is offline   Reply With Quote
Old 08-11-2015, 07:59 PM   #6
Senior Member
 
Join Date: Jan 2013
Posts: 465
Call customer service and get a RMA from them (return merchandise authorization) and ship it back. Let them inspect, adjust, and replace as necessary. The turnaround time is about six week at present. They have my Ultra CDP at the moment, and just received a new Solo last week.
My old Solo had several issues with Feed and ejection, was back there twice. I thought that was fixed, and after a couple hundred rounds the firing pin gave out. I sent it back the third time they had it about five weeks. Got the call about three weeks ago and they offered me a new gun. After long hard deliberation I went back with a replacement of the same color Solo.
The second time it went back I purchased a Sig P938 Equinox as a carry gun I already had a P238 and loved it. No problems or issues with either. The P-238 I have is five years old and goes bang every time.........
Attached Images
File Type: jpg IMG_2211.jpg (1.93 MB, 16 views)
Chuck43, Oreste and Cucamonga kid like this.
sbubrick is offline   Reply With Quote
Old 08-11-2015, 09:57 PM   #7
Senior Member
 
RustyIron's Avatar
 
Join Date: Aug 2014
Location: La Habra, California
Posts: 2,911
I wish I had some good thoughts or advice for you, but all I can say is send it back to the factory. Mine has been back twice. If you had asked prior to purchasing it, I would have strongly advised against it. Good luck.
Chuck43, Oreste, Zoomybaby and 1 others like this.
RustyIron is offline   Reply With Quote
Old 08-12-2015, 06:32 AM   #8
Member
 
Join Date: Aug 2015
Location: Pensacola, FL
Posts: 43
Here are some pictures. I had shot a friends when I was applying for my CC permit and was very impressed. He never mentioned he had sent his back to the factory. Wish I had done some research prior to jumping in with both feet. I still love it, but....

I had shot 7 different 9mm ammo types and had problems with all. After the factory work, I had no problems with the same ammo, which included remanufactured and reloads.
Many thanks for the moral support and suggestions.
Attached Images
File Type: jpg IMG_7880.JPG (76.6 KB, 7 views)
File Type: jpg IMG_7881.JPG (66.1 KB, 8 views)
File Type: jpg IMG_7876.JPG (81.3 KB, 20 views)
Metal Storm is offline   Reply With Quote
Old 08-12-2015, 09:50 AM   #9
Senior Member
 
RustyIron's Avatar
 
Join Date: Aug 2014
Location: La Habra, California
Posts: 2,911
That's a roll pin that retains the striker and prevents you from cleaning the channel. It should remain reasonably flush with the slide.
RustyIron is offline   Reply With Quote
Old 08-12-2015, 03:28 PM   #10
YuK
Member
 
YuK's Avatar
 
Join Date: Aug 2014
Location: Brooklyn NY
Posts: 91
Originally Posted by RustyIron View Post
That's a roll pin that retains the striker and prevents you from cleaning the channel. It should remain reasonably flush with the slide.
Flush or below. Designed to be below.
YuK is offline   Reply With Quote
Reply

Tags
problems, slide not sliding, solo


Search tags for this page

kimber solo extractor problems

Click on a term to search for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Had major problems at the range today Thor1030 Kimber Micro Carry Forum 11 05-26-2015 02:17 PM
Pro CDP II Feed Problems Richard Kimber 1911 Forum 40 01-21-2015 07:27 PM
1st Kimber - Problems Fixed. New Question wacowade Kimber 1911 Forum 9 03-22-2014 07:23 AM
New Kimber User. 1st Shoot problems wacowade Kimber 1911 Forum 16 03-20-2014 05:09 PM
Ext mag problems beastmanz Kimber Solo Forum 7 08-25-2013 03:20 PM