Kimbertalk.com banner

1 - 11 of 11 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
Hey guys I'm new to the forum and this is my first post/question. Just bought a camp guard this week and ran 50 rounds through at the range. Great trigger on the gun but... The first 5 rounds no problem (I was just loading 5 at a time in the mag) then every mag after that the slide stop would engage on the second or third round. By the last 5 rounds it did it on every shot. This is my third kimber I have a tactical custom and a two tone custom. I don't think it's something I'm doing. Any thoughts? Any advice is welcome.
 

·
Registered
Joined
·
1,795 Posts
Check the bottom of the slide stop lobe for brass or copper color transfer. Sounds as though it needs relieved. The second round down in the mag is bumping it up. It won't happen with all ammo but should not happen with any. The base to ogive length does it. Good you discovered it soon. Or call Kimber they tend to send out replacements that they hand work when people find the problem. Some never do.
 

·
Super Moderator
Joined
·
37,251 Posts
Welcome to the forum from northern Illinois Djm374 and congratulations on the new Camp Guard. I've been waiting for one to show up in a LGS but so far no luck. I think Mike gave you some good advice, give the slide stop a check.

How about stopping by our "New Member Introduction" sub forum and introducing yourself to the membership?
 

·
Registered
Joined
·
1,684 Posts
I seen the post and got to wondering what a Camp Guard is, checked the Kimber site, I know now. Welcome to the forum from a Middle Tennessee. Looking at Kimber's price for one...you should know have any problems.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #6
Welcome to the forum from northern Illinois Djm374 and congratulations on the new Camp Guard. I've been waiting for one to show up in a LGS but so far no luck. I think Mike gave you some good advice, give the slide stop a check.

How about stopping by our "New Member Introduction" sub forum and introducing yourself to the membership?
Thank you for the welcome. I ordered my camp guard in March and just came in this week. Not to happy this is occurring my LGS thinks it needs more break in time but I'm not so sure.
 

·
Super Moderator
Joined
·
37,251 Posts
Thank you for the welcome. I ordered my camp guard in March and just came in this week. Not to happy this is occurring my LGS thinks it needs more break in time but I'm not so sure.
Your LGS could very well be right, some of my best Kimbers were a little rough to start with. Clean and lube the gun frequently during the initial break in and stick with FMJ loads. Check the slide stop as Mike suggested or give Kimbers Customer Service a call and see what they suggest.
 
  • Like
Reactions: Markie

·
Registered
Joined
·
4,175 Posts
Welcome from southern CA.! I am sure you will get your 10 mm running right. I have the Eclipse 10 MM. I really enjoy shooting that 10 mm rd.
 

·
Registered
Joined
·
1,676 Posts
Welcome to the forum from GA. I too did not know what a Camp Guard 10 is and had to go to the site...beautiful pistol! Sorry that you are having problems. I hope you get it running right soon. Post photos and range reports too! :)
 
  • Like
Reactions: Markie

·
Super Moderator
Joined
·
37,251 Posts
Welcome to the forum from northern Illinois PetrK, how about stopping by our "New Member Introduction" sub forum and introducing yourself to the membership?
 
1 - 11 of 11 Posts
Top