Kimber Talk Forums banner

1 - 20 of 30 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My new solo jams. I realize a new gun has tight springs etc, but this one does not chamber 5 out of 8 rounds. I have to manually pull back the slide to catch the cartridge and release it so it chambers.This has happened with my Hornady hollow points (recommended ammo) and my Remington 9 mm 115 gr shells.
Any suggestions?
 

·
Super Moderator
Joined
·
37,618 Posts
Welcome to the forum dpak. I have to ask if you broke the Solo down and gave it a good cleaning and lube before you took it to the range as Kimber recommends? Second did you read this ammo recommendation? USE ONLY RECOMMENDED AMMUNITION Solo is designed to function optimally using premium hollow-point self-defense factory ammunition with bullet weights of 124 or 147 grains.
 

·
Registered
Joined
·
465 Posts
I two, along with a lot of people, are having the same problems!
Keep calling Kimber and complain! Some Solo's run fine, some are a pice of crap.
Check out the videos on utube!
Going out shooting in the morning, and will try a few more things, some different ammo, check with some professionals at our Clark County Shooting Park...
Stay tuned, more tomorrow night.............
 

·
Registered
Joined
·
465 Posts
I have a PDF file that was sent to me on the Solo, it talks about yours and my problems. I have tried to post it here, but unsuccessful at this point.
 

·
Registered
Joined
·
16 Posts
One of the things I have noticed with the solo is, you need a firm grip, if you limp wrist this weapon it will miss feed. It has such a short slide that a limp wrist will cause enough loss of recoil force to fail to eject the shell. Just my opinion for what it is worth.
 

·
Registered
Joined
·
465 Posts
As promissed, todays range report! The first three magazines (18 rounds) Speer Gold dot 124 GR. HP. I had.. First mag. 1 FTE round 4. Second mag 1st round FTL. Once loaded all rounds went down range. Third mag. 3rd. round FTE.
Switched to 100 rounds of American Eagle 147 grain Full Metal Jacket Flat point.
5 FTE's out of the hundred. Then 50 rounds of the same in 124 grain, 6 rounds failed to Eject. The 147's are snappy in the little Solo..........
Switched to my Ruger SR9C and ran 200 through, no problems all fed and ejected the way its supposed to.
Ran another 100 in my Tanfoglio TZ75 by Fie (import from Italy) Haven't fired that gun in about 8 years. Nice gun no problems, ran flawlessly This gun is all steel, because of the weight of it, maybe 1 tenth of the recoil that the Solo has..........................
 

·
Registered
Joined
·
1,553 Posts
I hate to hear another Solo problem. I have one and it runs fine with the recommended ammunition. Sbubrick, I would love to see that PDF file if you ever can get it loaded. Kimber needs to resolve these issues with the Solo now if indeed it is a problem with the weapon.
 

·
Registered
Joined
·
64 Posts
My local gun store told me of feeding issues with the early production Kimber SOLO with more than a few being sent back to Kimber for correction.

My SOLO was purchased around early March 2013 and has been trouble free.

(after first being stripped down, cleaned and lubed with Slide Glide on all frame/slide/barrel contact areas)

I hope Kimber has finally fixed whatever feeding/ejection issues with the little SOLO, as the gun has earned a bad rap from many shooters.

As always, YMMV!
 

·
Registered
Joined
·
11 Posts
Wanted the solo for some time until I found one at my local SG store. Sales told me they had sent it back to kimber because the mag release was so hard, I had to use both hands to depress it and then pull the mag out with one hand while holding the solo with the other. I thought that was ridiculous. They said Kimber sent it back to them and said the gun was within spec. They'll never sell it. I hope were not seeing a QC trend here. My pro carry performs beautifully, as 45, and with the 22lr conversion. I love it
 

·
Registered
Joined
·
64 Posts
Magazine release on my SOLO was rather stiff when new. It took some dabs of TW25b and exercising the button to free it up.

IMO, Kimber QC should catch these issues BEFORE the SOLO leave the factory.

As always, YMMV.
 

·
Registered
Joined
·
2 Posts
Kimber Solo FTL issue

Hello.,new to the forum, new Kimber Solo owner. Unfortunately, I appear to have a serious FTL issue with my pistol. I broke it down, cleaned and lubed before firing. I used premium 124gr JHP and experienced a 90% ftl rate (I am able to load the round by pulling the slide further back and releasing), switched to some american eagle 124gr fmj with the same results. I brought it home, performed another thorough cleaning/lube and am waiting to try it again.

I expected more from this pistol due to the brand name and price point. I have plenty of other pistols that just work. This is a disappointment.

I haven't dealt with Kimber support before, but I am already starting to investigate my options due to the poor initial showing :confused:

Update: after reviewing the assembly video I am not entirely confident I had the assembly spring inserted correctly. It is now, but I can't be for sure it was when I shot earlier today and from everything I have been reading it makes sense for the number of ftl 's I experienced. Looking forward to getting back to the range.
 

·
Super Moderator
Joined
·
37,618 Posts
Welcome to the forum from northern Illinois Pjcostanza. It sounds like you've done everything according to the owners manual. Kimbers customer service is one of the best in the industry. Give them a call and let them know what's going on with your Solo.

Customer Service
Toll-Free: (888) 243-4522
Hours: M-F, 9 a.m.-7 p.m. Eastern
 

·
Super Moderator
Joined
·
5,182 Posts
Welcome to the forum. Chucks advice is sound. Good luck with your Solo. I'm sure Kimber will resolve your problem.
 

·
Registered
Joined
·
2,228 Posts
Dpac and Pjcostanza welcome to the forum. I hope you get your Solo's figured out soon.
 

·
Registered
Joined
·
260 Posts
Welcome Pjcostanza and Dpac,

I have an early Solo, one of the first out, Let your mags sit fully loaded for a few weeks and make sure that spring gets captured on re-assembly.
Many tear down and reassemble their Solo with out looking closely at the instructions. (ask me how I know)
Mine had barrel lug peening but fed, fired and ejected everything I put through it. Sent it in to Kimber, they replaced the entire slide and barrel, she still shoots great and is my go to when I need to carry a smaller arm.

Good luck and keep us informed on yours.

J.W.

P, I saw your update
 

·
Registered
Joined
·
11,761 Posts
Welcome from Georgia.
 

·
Registered
Joined
·
19,361 Posts
My girlfriends ex-Solo had issues with fte/ftf and after sending it back to Kimber several times they finally resolved the issue.They adjusted the ejector and replaced the recoil spring and when we got it back she ran like a charm.Gf eventually sold the Solo and bought herself an Ultra Tle 45 and I just talked to the gentlemen we sold it to and it's still shooting without any issues...Good luck and hang in there.
 

·
Registered
Joined
·
2 Posts
Hello.,new to the forum, new Kimber Solo owner. Unfortunately, I appear to have a serious FTL issue with my pistol. I broke it down, cleaned and lubed before firing. I used premium 124gr JHP and experienced a 90% ftl rate (I am able to load the round by pulling the slide further back and releasing), switched to some american eagle 124gr fmj with the same results. I brought it home, performed another thorough cleaning/lube and am waiting to try it again.

I expected more from this pistol due to the brand name and price point. I have plenty of other pistols that just work. This is a disappointment.

I haven't dealt with Kimber support before, but I am already starting to investigate my options due to the poor initial showing :confused:

Update: after reviewing the assembly video I am not entirely confident I had the assembly spring inserted correctly. It is now, but I can't be for sure it was when I shot earlier today and from everything I have been reading it makes sense for the number of ftl 's I experienced. Looking forward to getting back to the range.
UPDATE: Issues resolved! User error. If the pin doesn't catch the small spring during re-assembly, the pistol won't load new rounds from the clip correctly. I re-assembled my Solo, ensuring that the pin caught the spring correctly, test fired a few clips and had ZERO ftls. :eek:)
Thanks to everyone that posted on this site for leading me to the problem and quick resolution. I went from very unhappy to very happy and learned a few things along the way!
 
1 - 20 of 30 Posts
Top